Skip to content

oneks fails with user non-owned networks because CAPONE does not support for VNET IDs #8128

Description

@OpenNebulaSupport

Description
In oneKS, if a user instantiates a Kubernetes cluster with a non-owner network, the virtual router creation process fails because the user for the network is needed (two different users can have a network with the same name)

Use case
If a virtual network wants to be used to create kubernetes clusters by multiple users, only the owner of that network will be able to use it. A workaround is reserving a number of IPs on that network and changing the owner of the reservation to the required user.

Interface Changes
In theory, no change should be needed: the VNET should be identified by its ID instead of its name. Being able to set up additional NIC parameters for the virtual router may be a good idea, though.

Additional Context
Ask for more context if needed

Progress Status

  • Code committed
  • Testing - QA
  • Documentation (Release notes - resolved issues, compatibility, known issues)

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions