When an error is encountered creating an actor, statusMessage is populated with informative detail as to what might have caused the issue. Here's an example:
"statusMessage": "Unable to start worker; error: Got exception trying to run container from image: abaco/core:0.11.0. Exception: 500 Server Error: Internal Server Error (\"devmapper: Thin Pool has 30979 free data blocks which is less than minimum required 31128 free data blocks. Create more free space in thin pool or use dm.min_free_space option to change behavior\")"
We don't easily know which Abaco host this has occurred on, which makes investigating just a bit harder than it needs to be. I suggest we consider including hostname or other identifier in statusMessage to assist in the process.
When an error is encountered creating an actor,
statusMessageis populated with informative detail as to what might have caused the issue. Here's an example:We don't easily know which Abaco host this has occurred on, which makes investigating just a bit harder than it needs to be. I suggest we consider including hostname or other identifier in
statusMessageto assist in the process.