Skip to content

HOSTNAME is not properly resolved in setup-apache-ssl-key #111

Description

@igor-bn

Hi,
thank you for keeping the image up to date and maintaining it! I faced with some issues while requesting new Lets Encrypt certificate from l3iggs/owncloud:latest (aka 9.1.2-1).

Here is the first issue.
setup-apache-ssl-key first failed with output like this:

This container's Apache server must be reachable from the Internet via http://home-net
Saving debug log to /var/log/letsencrypt/letsencrypt.log
...
  File "/usr/lib/python2.7/site-packages/acme/client.py", line 565, in _check_response
    raise messages.Error.from_json(jobj)
Error: urn:acme:error:malformed :: The request message was malformed :: DNS name does not have enough labels
...

The problem here is that "home-net" is not a full host name, but just a first part before the dot

I found out that following expression did not work properly (setup-apache-ssl-key#34):
: ${HOSTNAME:=$(hostname --fqdn)}

Not sure what it does, but simple assignment just works fine for me
HOSTNAME=$(hostname --fqdn)

Can you please check if you have the same issue with the image?

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions